Azure Cloud Support Engineer — Learning Package

SECTION A: Hands-on Labs

SECTION B: Major Projects

SECTION C: Gotchas

SECTION D: Playbook

P1 Incident Response

Common KQL Queries

// Failed logins
SigninLogs
| where ResultType != 0

// High CPU VMs
Perf
| summarize avg(CounterValue) by Computer

// NSG denied traffic
AzureDiagnostics
| where action_s == "Deny"

// HTTP 5xx errors
AppServiceHTTPLogs
| where ScStatus >= 500

Alert Tuning